MT-4E Receiver Firmware

Product Family
MT-4E Series
Description

MT-4E Receiver Firmware and Firmware Flashing Software


Requirements:

  • Firmware Flashing Software Version 1.9.3.0 or later, if not previously installed.
  • Radio Service Software 4E Radios (RSS4E) Version 1.7.6 or later.

Note:

  • This update can only be applied to firmware versions 2.0.0 and later.
  • Refer to the release note for flashing instructions.
  • Do not use an external USB hub for programming the radio.
  • Do not use a USB cable that is longer than 10 feet for programming the radio.

Downloads

Version
2.9.9
Description
  • Bug fix for Battery Level Reporting Operation.
  • Status Tone feature is now available to all users.
  • Minor bug fixes.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: This version of firmware requires RSS 1.7.6.0 or above to access the latest features.

Release Date
27 March 2018
Filesize
4.3MB
Version
2.0.0
Description


MT-4E Receiver Bootloader and V2.0.0 Firmware

This is the first update that is required to go from version 1.6 to version 2.0 or later.

For earlier firmware versions please contact the service department to obtain an RMA number and shipping instructions.

Requirements:

Note: The latest firmware version must also be applied after v2.0.0.

Release Date
18 March 2008
Filesize
1.3MB

Version History

Version 2.9.9 27 March 2018
  • Bug fix for Battery Level Reporting Operation.
  • Status Tone feature is now available to all users.
  • Minor bug fixes.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: This version of firmware requires RSS 1.7.6.0 or above to access the latest features.

Version 2.9.8 1 March 2017
  • Battery Level Reporting feature. Requires Transmitter Firmware 2.10.9 or later.
  • Remote keying (through DTMF) of P25 Receiver Standard Tone Test Pattern (TIA-102.CAAAA Section1.3.3.7 a). Requires Transmitter Firmware 2.10.9 or later.
  • RSSI Response for P25CC. (P25CC Voting Application specific feature.)

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact factory in this case.

Version 2.9.6 1 September 2015
  • Added a receiver health indication feature.
  • Added the capability to indicate whether a P25 group call or a P25 unit-to-unit call is being received.
  • Added the capability to assign a different function to certain output pins. See help file in RSS ver 1.7.4.0 or above for detail.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: This version of firmware requires RSS 1.7.4.0 or above to access the latest features.

Version 2.9.5 1 June 2015
  • Added a repeat Simple TDU and Extended TDU feature.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.2.1 or above.

Note: This version of firmware requires RSS 1.7.3.0 or above to access the latest features.

Version 2.9.0 1 August 2014
  • Improvement with receiver start up.
  • Fix the non-linear RSSI response.
  • Improvement for simulcast application.
  • Improve FM demodulator routine.
  • Add automatic reboot after decryption key is zeroized.

Note: If an unsupported encryption module (Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact Codan in this case.

Note: Balanced Audio, Speaker Audio, Disc (Discriminator), and Disc (Discriminator) LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.7.5 or earlier this version.

Note: This version of firmware requires RSS 1.7.0.0 or above to access the latest features.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: Due to hardware differences, some radios with firmware version 2.7.5 or above cannot be downgraded. Contact factory if further details are required.

Version 2.7.50 3 September 2012
  • Improve DCS decoding in the multi-channel operating application.
  • Improve the decoding Inverted DCS.

Note: If an unsupported encryption module (Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact Codan in this case.

Note: Balanced Audio, Speaker Audio, Disc (Discriminator), and Disc (Discriminator) LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.7.5 or earlier this version.

Note: This version of firmware requires RSS 1.6.3.0 or above to access the latest features.

Note: This version of firmware requires Firmware Flashing Software 1.7.3.0 or above.

Note: Due to hardware differences, some radios with firmware version 2.7.5 or above cannot be downgraded. Contact factory if further details are required.

Version 2.7.5 3 September 2012
  • Support for new Flash IC.

Note: If an unsupported encryption module (Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact Codan in this case.

Note: Balanced Audio, Speaker Audio, Disc (Discriminator), and Disc (Discriminator) LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: This version of firmware requires RSS 1.6.0.0 or above.

Note: This version of firmware requires Firmware Flashing Software 1.7.0.0 or above.

Note: Due to hardware differences, some radios with firmware version 2.7.5 or above cannot be downgraded. Contact factory if further details are required.

Version 2.7.49 1 November 2011
  • Expand the capability of the startup diagnostic module.
  • Adding support for MPT1327 trunk controller.
  • Improve digital adjacent channel rejection performance.
  • Add option to wait for AlgID before unsequleching when crypto module is installed.
  • Improve DCS decoding performance.

Note: If an unsupported encryption module (Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact Codan in this case.

Note: Balanced Audio, Speaker Audio, Disc (Discriminator), and Disc (Discriminator) LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading to this version

Note: This version of firmware requires RSS 1.6.3.0 or above to access the latest features.

Note: This version of firmware requires Firmware Flashing Software 1.7.3.0 or above.

Note: Due to hardware differences, some radios with firmware version 2.7.5 or above cannot be downgraded. Contact factory if further details are required.

Version 2.6.9 1 June 2011
  • Enhance synthesizer diagnostic during startup.

Note: If an unsupported encryption module (Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Rx firmware is upgraded to this version. Please contact Codan in this case.

Note: Balanced Audio, Speaker Audio, Disc (Discriminator), and Disc (Discriminator) LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: This version of firmware requires RSS 1.6.0.0 or above.

Note: This version of firmware requires Firmware Flashing Software 1.6.1 or above.

Version 2.4.2 1 February 2011
  • Change the impulse response of the CTCSS smoothing filter.
  • Enhance the RSSI DAC output operation.
  • Enhance the bit error rate test operation when BER is higher than 5%.
  • Enhance the status tone operation when high amplitude is selected.
  • Improve the track of secure signal indication under low signal level condition.
  • Supports FIPS certified version of ENCRYPT-MT4E-XX1. However, the Non-FIPS certified version of ENCRYPT-MT4E-XX1 is not supported.
  • ENCRYPT-MT4E-XX is not supported.

Note: If an unsupported encryption module is installed in the unit to be flash upgraded, it will no longer work if the firmware is upgraded to 2.2.15 code or above. Please contact Codan in this case.

Note: Balanced Audio, Speaker Audio, Disc, and Disc LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: This version of firmware requires RSS 1.5.9.0 or above.

Version 2.2.9 1 October 2009
  • Reduce the status tone gap during squelching and unsquelching.
  • Supports ENCRYPT-MT4E-XX.
  • Adjustment for the CTCSS smoothing filter.

Note: Balanced Audio, Speaker Audio, Disc, and Disc LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: This version of firmware requires RSS 1.4.6.0 or above.

Version 2.2.2 2 March 2009
  • Fix the problem with multiple reset happening during configuration parameter programming.

Note: Balanced Audio, Speaker Audio, Disc, and Disc LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: This version of firmware requires RSS 1.4.6.0 or above.

Version 2.2.1 2 February 2009
  • Add support for 800 MHz band.
  • Add support for the encryption module, ENCRYPT-MT-4E-XX (FIPS Certified).
  • Add option for Noise Based Squelch Operation.
  • Improve FM demodulator algorithm.
  • Output of the FM demodulator is now routed to the DISC o/p.
  • Increase the pass band of the DISC o/p.

Note: Balanced Audio, Speaker Audio, Disc, and Disc LPF outputs need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: Squelch Open and Close points need to be readjusted after upgrading from version 2.1.1 or earlier to this version.

Note: This version of firmware requires RSS 1.4.6.0 or above.

Version 2.1.1 2 June 2008
  • Bypass the voice band filter when in P25 mode to improve the sensitivity when receiving encrypted signals.
  • Add field flashing capability.
  • Change RSSI output to log scale.
Version 2.0.0 18 March 2008


MT-4E Receiver Bootloader and V2.0.0 Firmware

This is the first update that is required to go from version 1.6 to version 2.0 or later.

For earlier firmware versions please contact the service department to obtain an RMA number and shipping instructions.

Requirements:

Note: The latest firmware version must also be applied after v2.0.0.

Challenging requirements?
Speak to an expert today to design your solution.