MT-4E Transmitter Firmware

Product Family
MT-4E Series
Description

MT-4E Transmitter Firmware and Firmware Flashing Software


Requirements:

  • Firmware Flashing Software Version 1.9.3.0 or later, if not previously installed.
  • Radio Service Software 4E Radios (RSS4E) Version 1.7.6 or later.


Note
:

  • This update can only be applied to firmware versions 2.0.0 and later.
  • Refer to the release note for flashing instructions.
  • Do not use an external USB hub for programming the radio.
  • Do not use a USB cable that is longer than 10 feet for programming the radio.

Downloads

Version
2.10.18
Description
  • Advanced support for upcoming product features and hardware alternatives.
  • Fix for transmitter output power fault experienced in select units.
  • Other minor bug fixes.

Hardware Compatibility

The v2.10.18 transmitter firmware upgrade is compatible with all versions of MT-4E Transmitter hardware. Note that optional encryption modules purchased prior to 2009 are no longer supported.

If you are unsure of the compatibility of your encryption modules or have any other questions or concerns, please contact LMRSupport@codancomms.com.

Software Compatibility

  • Codan MT-4E Firmware Flashing Software 1.9.3.0 or above required.
  • This version of firmware requires Codan MT-4E Radio Service Software (RSS) v1.7.7.0 or above required to access the latest features.
Release Date
9 October 2019
Filesize
4.4MB
Version
2.0.0
Description

MT-4E Transmitter Bootloader and V2.0.0 Firmware.

This is the first update that is required to go from version 1.6 to version 2.0 or later.

For earlier firmware versions please contact the service department to obtain an RMA number and shipping instructions.


Requirements:

Note: The latest firmware version must also be applied after v2.0.0.

Release Date
18 March 2008
Filesize
1.5MB

Version History

Version 2.10.18 9 October 2019
  • Advanced support for upcoming product features and hardware alternatives.
  • Fix for transmitter output power fault experienced in select units.
  • Other minor bug fixes.

Hardware Compatibility

The v2.10.18 transmitter firmware upgrade is compatible with all versions of MT-4E Transmitter hardware. Note that optional encryption modules purchased prior to 2009 are no longer supported.

If you are unsure of the compatibility of your encryption modules or have any other questions or concerns, please contact LMRSupport@codancomms.com.

Software Compatibility

  • Codan MT-4E Firmware Flashing Software 1.9.3.0 or above required.
  • This version of firmware requires Codan MT-4E Radio Service Software (RSS) v1.7.7.0 or above required to access the latest features.
Version 2.10.9 23 March 2017
  • Option to have the synthesizer remain on all the time.
  • Option to have adjustable courtesy tone.
  • Battery Level Reporting feature. Requires Receiver Firmware 2.9.8 or later.
  • Remote keying (through DTMF) of P25 Receiver Standard Tone Test Pattern (TIA-102.CAAAA Section 1.3.3.7 a). Requires Receiver Firmware 2.9.8 or later.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit when the Tx firmware is upgraded then it may no longer function. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: This version of firmware requires RSS 1.7.6.0 or above to access the latest features.


Version 2.10.6 1 July 2016
  • During manufacturing, some units are identified to have consistently taken too long to start from power up. A firmware fix is implemented to address this issue.
  • Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit when the Tx firmware is upgraded then it may no longer function. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: This version of firmware requires RSS 1.7.5.0 or above to access the latest features.

Version 2.10.4.46 1 February 2016
  • Added the capability to assign Tx health status indication operation to Pin Z-26.
  • Added support for loss of network connection alert feature.
  • Minor bug fixes.


Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit when the Tx firmware is upgraded then it may no longer function. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.3.0 or above.

Note: This version of firmware requires RSS 1.7.5.0 or above to access the latest features.

Version 2.10.1.46 1 June 2015
  • Added a repeat Simple TDU and Extended TDU feature.
  • Trunking control channel operation stability improved.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Tx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.2.1 or above.

Note: This version of firmware requires RSS 1.7.3.0 or above to access the latest features.

Version 2.9.36.46 1 May 2014
  • Rebranding to Codan Radio Communications.
  • Add Digital Ping feature.
  • Add support to P25 Channel Controller application.
  • Add support to P25 Channel Controller Simulcast application.
  • Minor bug fixes.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Tx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.9.2.1 or above.

Note: This version of firmware requires RSS 1.6.9.0 or above to access the latest features.

Version 2.9.11.40 3 December 2012
  • FCC Part 90.203 compliance

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Tx firmware is upgraded to this version. Please contact factory in this case.

Note: This version of firmware requires Firmware Flashing Software 1.8.0.0 or above.

Note: This version of firmware requires RSS 1.6.5.0 or above to access the latest features.

Version 2.7.52 3 September 2012
  • Expand the capability of the startup diagnostic module.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Tx firmware is upgraded to this version. Please contact Codan in this case.

Note: This version of firmware requires Firmware Flashing Software 1.7.3.0 or above.

Note: This version of firmware requires RSS 1.6.3.0 or above to access the latest features.

Version 2.7.8 1 December 2011
  • Support for new Flash IC.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Tx firmware is upgraded to this version. Please contact Codan in this case.

Note: This version of firmware requires Firmware Flashing Software 1.7.0.0 or above.

Note: This version of firmware requires RSS 1.6.0.0 or above.

Note: Due to hardware differences, some radios with firmware version 2.7.8 or above cannot be downgraded. Contact factory if further details are required.

Version 2.6.7 1 November 2011
  • Enhance synthesizer diagnostic during startup.

Note: If an unsupported encryption module (the Non-FIPS certified version of ENCRYPT-MT4E-XX1) is installed in the unit to be flash upgraded, it will no longer work if the Tx firmware is upgraded to this version. Please contact Codan in this case.

Note: This version of firmware requires Firmware Flashing Software 1.6.1 or above.

Note: This version of firmware requires RSS 1.6.0.0 or above.

Version 2.4.9 1 July 2011
  • Widen the lower pass band limit of the pre-emphasis filter.
  • Widen the lower pass band limit of the shaping filter.
  • During transparent mode transmit, only turn on PA when transparent data packet has been received.
  • Enhance the External Subtone Input operation in Analog Transparent mode.
  • Adding lower standby current mode feature.
  • Provide more option for Status Symbol Operation.
  • Supports FIPS certified version of ENCRYPT-MT4E-XX1. However, the Non-FIPS certified version of ENCRYPT-MT4E-XX1 is not supported.
  • ENCRYPT-MT4E-XX is not supported.
  • New tuning parameter interpolation for the 768 to 869 MHz band.
  • Enhance the NPSPAC band operation.

Note: If an unsupported encryption module is installed in the unit to be flash upgraded, it will no longer work if the firmware is upgraded to 2.2.14 code or above. Please contact Codan in this case.

Note: This version of firmware requires RSS 1.5.9.0 or above.

Version 2.2.7 1 September 2009
  • Supports ENCRYPT-MT4E-XX.

Note: This version of firmware requires RSS 1.4.6.0 or above.

Version 2.2.2 2 March 2009
  • Address the issue with some transmitters occasionally can fail to come out of the initialization after power up.

Note: This version of firmware requires RSS 1.4.6.0 or above.

Version 2.2.1 2 February 2009
  • Add support for 800 MHz band (include NPSPAC band option).
  • Add support for the encryption module, ENCRYPT-MT-4E-XX (FIPS Certified).
  • When using a "Paging" channel type, allow switching between analog vs. digital paging after PTT is asserted.
  • The hang time operation has changed. Now when tail type TDU only is selected for a mixed mode channel, analog operation will have silent squelch tail.
  • Add carrier offset adjustment when external sub-tone input selected.
  • Improve tone encoding capability of the P25 vocoder.

Note: This version of firmware requires RSS 1.4.6.0 or above.

Version 2.1.0 1 February 2008
  • Add field flashing capability.
  • Add code for simulcast operation.
  • Add code to support forward and reverse power alarms.
Version 2.0.0 18 March 2008

MT-4E Transmitter Bootloader and V2.0.0 Firmware.

This is the first update that is required to go from version 1.6 to version 2.0 or later.

For earlier firmware versions please contact the service department to obtain an RMA number and shipping instructions.


Requirements:

Note: The latest firmware version must also be applied after v2.0.0.

Challenging requirements?
Speak to an expert today to design your solution.